Python GUI-projektet

senaste versionen-2.5.4

fungerar nu med Python 3 på MacOSX och Windows!
(Python3-stöd för Gtk måste vänta tills Gtk 3 och relaterade bibliotekär stabila och snabba med GObject Introspection.)
ScrollableView-klassen har implementerats helt på Windows och bör nu fungera korrekt med alla byggnader av PyWin32.

bläddra

skärm
dokumentation
innehåller handledning material, exempel kod och API referens
förändringar

hämta

PyGUI-2.5.4.tjära.gz
Senast uppdaterad 25 Mar 2017

denna version innehåller tre implementeringar:

  • MacOSX-kräver PyObjC (testad Med PyObjC – 1.2 på Tiger, PyObjC-2.3 på Snow Leopard)
  • Linux-kräver pygtk (testad med pygtk – 2.14.0 och Gtk+-2.14.7)
  • Windows-kräver pywin32 (testad med pywin32-213) och ctypes (medföljer Python 2.5 och senare)

Python-versioner krävs:

  • Python 2: 2.3 eller senare
  • Python 3: 3.1 eller senare

för att använda OpenGL-anläggningarna behöver du PyOpenGL och, för GTK-versionen,Gtkglextoch PyGtkGLExt.
föråldrade versioner

exempel

exempel ansökan: blobedit.py
du kan också hitta innehållet i mappen tester idistribution användbar som en källa till exempelkod.

diskussion

Pygui Mailing List-för alla diskussioner som rör utveckling och användning av PyGUI.
pyobjc,PyGtkand PyWin32mailing listor kan också vara lämpliga för plattformsspecifika frågor.

bekräftelser

vissa delar av Windows-implementeringen är baserade på bidrag frånpatrick Forget och Erez-Sh. Även om jag inte använde mycket av deras Kodi slutändan uppskattar jag deras ansträngningar och kan dra mer av det i framtiden.

Lämna ett svar

Din e-postadress kommer inte publiceras.