projekt Python GUI

najnowsza wersja – 2.5.4

teraz działa z Pythonem 3 Na MacOSX i Windows!
(Obsługa Python3 dla Gtk będzie musiała poczekać, aż Gtk 3 i powiązane biblioteki będą stabilne i szybkie z introspekcją GObject.)
Klasa ScrollableView została całkowicie zaimplementowana w systemie Windows i powinna teraz działać poprawnie ze wszystkimi kompilacjami PyWin32.

Przeglądaj

zrzuty ekranu
dokumentacja
zawiera materiał samouczka, przykładowy kod i odniesienie do API
zmiany

Pobierz

PyGUI-2.5.4.smoła.gz
Ostatnia aktualizacja 25 Mar 2017

ta wersja zawiera trzy implementacje:

  • MacOSX-wymaga PyObjC (testowane z PyObjC-1.2 Na Tiger, PyObjC-2.3 Na Snow Leopard)
  • Linux-wymaga pygtk (testowane z pygtk-2.14.0 i Gtk+-2.14.7)
  • Windows-wymaga pywin32(testowane z pywin32-213) i ctypes (zawarte w Pythonie 2.5 i nowszych)

wymagane wersje Pythona:

  • Python 2: 2.3 lub nowszy
  • Python 3: 3.1 lub nowszy

aby korzystać z funkcji OpenGL, będziesz potrzebował PyOpenGL,a dla wersji Gtk, Gtkglext i PyGtkGLExt.

przykłady

przykładowe zastosowanie: blobedit.py
możesz również znaleźć zawartość folderu Tests w dystrybucji jako źródło przykładowego kodu.

dyskusja

PyGUI Lista mailingowa — dla wszystkich dyskusji związanych z rozwojem i wykorzystaniem PyGUI.
listy wysyłkowe PyObjC,PyGtkand PyWin32 mogą być również odpowiednie dla problemów związanych z platformą.

podziękowania

niektóre części implementacji Windows są oparte na wkładach byatrick Forget i Erez-Sh. Mimo, że w końcu nie wykorzystałem ich kodu, doceniam ich wysiłki i mogę czerpać z niego więcej w przyszłości.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.