Python GUI-projekti

uusin versio-2.5.4

toimii nyt Python 3: n kanssa MacOSX: ssä ja Windowsissa!
(Python3-tuki Gtk: lle joutuu odottamaan, kunnes Gtk 3 ja siihen liittyvät kirjastot ovat vakaita ja ajan tasalla gobject-itsetutkiskelun avulla.)
ScrollableView-luokka on täysin reimplemented Windowsissa ja sen pitäisi nyt toimia kunnolla kaikkien pywin32: n rakennelmien kanssa.

Selaa

kuvakaappauksia
dokumentaatio
Sisältää opetusmateriaalia, esimerkkikoodin ja API-viitteen
muutokset

lataus

PyGUI-2.5.4.tervaa.gz
päivitetty viimeksi 25.3.2017

tämä versio sisältää kolme toteutusta:

  • MacOSX-vaatii Pjobjc (testattu Pjobjc – 1.2 Tigerilla, Pjobjc-2.3 Lumileopardilla)
  • Linux-vaatii pygtk: n(testattu pygtk-2.14.0: lla ja Gtk: lla+-2.14.7)
  • Windows-vaatii pywin32 (testattu pywin32-213: lla) ja ctypes (mukana Python 2.5 ja uudemmat)

Python-versiot vaaditaan:

  • Python 2: 2.3 tai uudempi
  • Python 3: 3.1 tai myöhemmin

OpenGL-laitteiden käyttöön tarvitaan PyOpenGL,ja Gtk-versiossa Gtkglext ja PyGtkGLExt.
ObsoleteVersions

Examples

Example application: blobedit.py
saatat myös havaita Testikansionjakelun sisällön hyödylliseksi esimerkkikoodin lähteeksi.

Keskustelu

PyGUI-postituslista — kaikille keskusteluille, jotka liittyvät Pyguin kehittämiseen ja käyttöön.
Pjobjc: n,PyGTK: n ja PyWin32mailing-listat voivat sopia myös alustakohtaisiin kysymyksiin.

kuittaukset

jotkin Windows-toteutuksen osat perustuvat torrick Forgetin ja Erez-Sh: n panoksiin. Vaikka en käyttänyt paljon heidän koodiaan loppujen lopuksi, arvostan heidän ponnistelujaan ja saatan ammentaa siitä lisää tulevaisuudessa.

Vastaa

Sähköpostiosoitettasi ei julkaista.